Форум программистов
 
Контакты: о проблемах с регистрацией, почтой и по другим вопросам пишите сюда - alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail.

Вернуться   Форум программистов > Web > WordPress и другие CMS
Регистрация

Восстановить пароль
Повторная активизация e-mail


Ответ
 
Опции темы
Старый 28.09.2010, 19:04   #1
dimzel
Новичок
 
Регистрация: 28.09.2010
Сообщений: 1
Репутация: 10
Восклицание MediaWiki 1.16.0 проблемы с установкой

Добрый вечер уважаемые форумчане!
для моей работы мне потребовалось иметь собственную википедию на своём локальном компе, но я не могу её поставить. точнее поставить-поставил, но существует некий баг, не дающий с ней работать, итак, по-порядку:

действовал по инструкции отсюда
http://lifehacker.com/354005/run-you...om-a-usb-stick

MediaWiki 1.16.0 скачал отсюда:
http://www.mediawiki.org/wiki/Download
и там же, на странице написано: Warning: PHP 5.3.1 has a bug in it and is not supported by MediaWiki. You should use PHP 5.3.0 or PHP 5.3.2 instead.

там же ссылка на этот баг, ведёт сюда http://bugs.php.net/bug.php?id=50394 (там указаны патчи, но я не знаю, как с ними работать.)

при переходе на http://localhost/wiki/ отображается страница с ссылкой-надписью please setup the wiki first, жму на неё и появляется следующая надпись:
PHP 5.3.1 is not compatible with MediaWiki due to a bug involving reference parameters to __call. Upgrade to PHP 5.3.2 or higher, or downgrade to PHP 5.3.0 to fix this. ABORTING (see http://bugs.php.net/bug.php?id=50394 for details)

подскажите плз, как исправить.
dimzel вне форума   Ответить с цитированием
Старый 12.10.2010, 13:22   #2
KPEATuBHO
Форумчанин
 
Аватар для KPEATuBHO
 
Регистрация: 03.09.2010
Сообщений: 197
Репутация: 28
По умолчанию

http://bugs.php.net/patch-display.ph...302&download=1

Это ссылка на файл. Когда вы его скачаете он будет называться MediaWiki.patch.txt его необходимо переименовать в php.ini и, если у вас установлен denwer, закинуть этот файл в [папка, где установлен денвер]/usr/local/php5. Тем самым вы пропатчите PHP для работы с MediaWiki
KPEATuBHO вне форума   Ответить с цитированием
Старый 26.12.2011, 18:46   #3
Bingam Vici
Форумчанин
 
Аватар для Bingam Vici
 
Регистрация: 28.12.2008
Адрес: Озерск
Сообщений: 144
Репутация: 65

icq: 442058704
По умолчанию

Сейчас установила Денвер (Denwer3_Base_2010-03-18_a2.2.4_p5.3.1_m5.1.40_pma3.2.3) создала викибд, создала директорию вики и положила туда файлы медиавики версии 1.16. Начинаю инсталировать, вылазит такая же фраза:

Цитата:
PHP 5.3.1 is not compatible with MediaWiki due to a bug involving reference parameters to __call. Upgrade to PHP 5.3.2 or higher, or downgrade to PHP 5.3.0 to fix this. ABORTING...
Снесла и переустановила Денвер, сначала инсталировала вики после setup the wiki first, и в ходе заполнения всех полей создала в phpMyAdmin бд wikidb и пользователя с паролем. Всё заработало без проблем.
__________________
Bingam
Bingam Vici вне форума   Ответить с цитированием
Ответ

Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
MediaWiki. Проблемы с отображением кириллицы в URL. Harima Hario WordPress и другие CMS 0 01.03.2010 18:49
Проблемы с установкой винды DerMeister Windows 11 15.12.2009 02:53
Проблемы с установкой компонента DrHouse Компоненты Delphi 2 26.11.2009 21:09
TShockwaveFlash проблемы с установкой! JRcoker Общие вопросы Delphi 2 02.08.2008 23:13
GLScene. Проблемы с установкой xPAL Свободное общение 0 03.07.2008 18:20


07:55.


Powered by vBulletin® Version 3.8.8 Beta 2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

RusProfile.ru


Справочник российских юридических лиц и организаций.
Проекты отопления, пеллетные котлы, бойлеры, радиаторы
интернет магазин respective.ru