Форум программистов
 
Контакты: о проблемах с регистрацией, почтой и по другим вопросам пишите сюда - alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail.

Вернуться   Форум программистов > Microsoft Office и VBA > Microsoft Office Excel
Регистрация

Восстановить пароль
Повторная активизация e-mail

Ответ
 
Опции темы
Старый 05.07.2018, 20:00   #1
Onehunter
Пользователь
 
Регистрация: 16.10.2010
Сообщений: 26
Репутация: 10
По умолчанию Поиск в ячейке нескольких слов (ИЛИ)

прошу подсказать.
нужно осуществлять поиск по содержимому ячеек (текстовое слово). как сделать по одному слову, вариант нашел -
(=ЕСЛИ(ЕЧИСЛО(ПОИСК("искомое_слово_ 1";D6));1;"")).

а как сделать по нескольким словам (ИЛИ)? вот так не пашет -
(=ЕСЛИ(ЕЧИСЛО(ПОИСК(ИЛИ("искомое_сл ово_1";"искомое_слово_2");D6));1;"" ))

можно ли использовать маски для таких слов?
сколько можно задать максимум перечислений? (потянет ли проверка по 5-10 словам)
Спасибо!

Последний раз редактировалось Onehunter; 05.07.2018 в 20:06.
Onehunter вне форума   Ответить с цитированием
Старый 05.07.2018, 20:14   #2
IgorGO
МегаМодератор
СуперМодератор
 
Аватар для IgorGO
 
Регистрация: 05.02.2008
Адрес: УКРАЇНА, Київ
Сообщений: 8,930
Репутация: 1648

icq: 7934250
skype: i2x0,5
По умолчанию

а что нужно в итоге?
узнать есть-ли в предложении хоть одно из слов?
__________________
41001804815208 - Яндекс-деньги благодарности за удачные советы и решения можно отправлять прямо сюда)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете
IgorGO на форуме   Ответить с цитированием
Старый 05.07.2018, 20:28   #3
Onehunter
Пользователь
 
Регистрация: 16.10.2010
Сообщений: 26
Репутация: 10
По умолчанию

Цитата:
Сообщение от IgorGO Посмотреть сообщение
а что нужно в итоге?
узнать есть-ли в предложении хоть одно из слов?
именно так. чтобы разграничить этот список (по тематикам, там заголовки, будем считать, неких книг), и потом сделать суммирование (будем считать, их стоимости)
Onehunter вне форума   Ответить с цитированием
Старый 05.07.2018, 20:28   #4
IgorGO
МегаМодератор
СуперМодератор
 
Аватар для IgorGO
 
Регистрация: 05.02.2008
Адрес: УКРАЇНА, Київ
Сообщений: 8,930
Репутация: 1648

icq: 7934250
skype: i2x0,5
По умолчанию

см.вложение
Вложения
Тип файла: xlsx Книга3.xlsx (9.1 Кб, 10 просмотров)
__________________
41001804815208 - Яндекс-деньги благодарности за удачные советы и решения можно отправлять прямо сюда)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете
IgorGO на форуме   Ответить с цитированием
Старый 05.07.2018, 23:21   #5
Onehunter
Пользователь
 
Регистрация: 16.10.2010
Сообщений: 26
Репутация: 10
По умолчанию

спасибо! немного, премудрое решение для меня. тк оно требует создания места под перечень этих ключевых слов. было бы удобней, их занести в формулу
Onehunter вне форума   Ответить с цитированием
Старый 06.07.2018, 00:47   #6
Казанский
Профессионал
 
Аватар для Казанский
 
Регистрация: 31.12.2010
Сообщений: 2,016
Репутация: 802
По умолчанию

Удобнее?! Ну дерзайте
Код:

=СУММ(СЧЁТЕСЛИ(A1;"*"&{"нужно";"осуществлять";"сделать";"и т.д."}&"*"))>0

Список слов ведь можно разместить на другом листе или даже в другой книге.
__________________
exceleved@yandex.ru Яндекс.Деньги: 410011500007619
Казанский вне форума   Ответить с цитированием
Старый 06.07.2018, 01:21   #7
Onehunter
Пользователь
 
Регистрация: 16.10.2010
Сообщений: 26
Репутация: 10
По умолчанию

Цитата:
Сообщение от Казанский Посмотреть сообщение
Удобнее?! Ну дерзайте
Код:

=СУММ(СЧЁТЕСЛИ(A1;"*"&{"нужно";"осуществлять";"сделать";"и т.д."}&"*"))>0

Список слов ведь можно разместить на другом листе или даже в другой книге.
во, спасибки! а то я по рабоче-крестьянски уже начал решать ) вот так -
=ЕСЛИ(ИЛИ(ЕЧИСЛО(ПОИСК("wordpress"; D2));ЕЧИСЛО(ПОИСК("[wp]";D2));ЕЧИСЛО(ПОИСК("wp ";D2)));1;"")
лишние листы создавать не хочется
Onehunter вне форума   Ответить с цитированием
Ответ

Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Поиск слов в ячейке базой, из других ячеек RockHammer Microsoft Office Excel 11 09.02.2018 03:05
Поиск нескольких слов в Memo1 Mik92 Общие вопросы Delphi 2 27.08.2014 17:17
Поиск одного из нескольких вариантов слов в заданной ячейке и перенос его вдругую ячейку ТвойПервый Microsoft Office Excel 19 06.03.2013 07:54
Дано предложение из нескольких слов, отделенных пробелом или запятой и пробелом, заканчивающейся точкой..... zzz6 Помощь студентам 5 12.07.2011 11:00
Поиск буквы (или нескольких букв) в слове Byurrer Общие вопросы C/C++ 9 09.04.2011 00:10


16:30.


Powered by vBulletin® Version 3.8.8 Beta 2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

RusProfile.ru


Справочник российских юридических лиц и организаций.
Проекты отопления, пеллетные котлы, бойлеры, радиаторы
интернет магазин respective.ru