Форум программистов
 
Контакты: о проблемах с регистрацией, почтой и по другим вопросам пишите сюда - alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail.

Вернуться   Форум программистов > Microsoft Office и VBA > Microsoft Office Excel
Регистрация

Восстановить пароль
Повторная активизация e-mail

Ответ
 
Опции темы
Старый 25.01.2019, 18:45   #1
кувикин
Новичок
 
Регистрация: 25.01.2019
Сообщений: 3
Репутация: 10
По умолчанию расчет затраченного времени между определенным рабочим времени

Столкнулся с такой проблемой. надо рассчитать сколько прошло рабочего времени например. 5 рабочих дней в неделе. выходные суббота и воскресенье, с 9-18 рабочее время. начали работать 09.01.2019 13:30 окончили 18.01.2019 16:40. Если такая формула ? или проще вручную рассчитывать.
кувикин вне форума   Ответить с цитированием
Старый 25.01.2019, 21:41   #2
IgorGO
МегаМодератор
СуперМодератор
 
Аватар для IgorGO
 
Регистрация: 05.02.2008
Адрес: УКРАЇНА, Київ
Сообщений: 9,102
Репутация: 1731

icq: 7934250
skype: i2x0,5
По умолчанию

есть такая формула:
Код:

=ЕСЛИ(ЦЕЛОЕ(A1)=ЦЕЛОЕ(B1);B1-A1;ЦЕЛОЕ(A1)+3/4-A1+B1-ЦЕЛОЕ(B1)-3/8+(ЦЕЛОЕ(B1)-ЦЕЛОЕ(A1)-1-СУММПРОИЗВ(--(ДЕНЬНЕД(СТРОКА(ИНДЕКС(A:A;ЦЕЛОЕ(A1)+1):ИНДЕКС(A:A;ЦЕЛОЕ(B1)-1));2)>5)))*3/8)

когда
в А1 начальное время
в В1 конечное время
__________________
41001804815208 - Яндекс-деньги благодарности за удачные советы и решения можно отправлять прямо сюда)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете
IgorGO вне форума   Ответить с цитированием
Старый 26.01.2019, 01:54   #3
кувикин
Новичок
 
Регистрация: 25.01.2019
Сообщений: 3
Репутация: 10
По умолчанию

Цитата:
Сообщение от IgorGO Посмотреть сообщение
есть такая формула:
Код:

=ЕСЛИ(ЦЕЛОЕ(A1)=ЦЕЛОЕ(B1);B1-A1;ЦЕЛОЕ(A1)+3/4-A1+B1-ЦЕЛОЕ(B1)-3/8+(ЦЕЛОЕ(B1)-ЦЕЛОЕ(A1)-1-СУММПРОИЗВ(--(ДЕНЬНЕД(СТРОКА(ИНДЕКС(A:A;ЦЕЛОЕ(A1)+1):ИНДЕКС(A:A;ЦЕЛОЕ(B1)-1));2)>5)))*3/8)

когда
в А1 начальное время
в В1 конечное время

Что та не выходит. не правильно считает. если не сложно. Можете загрузить таблицу. ?
кувикин вне форума   Ответить с цитированием
Старый 26.01.2019, 16:48   #4
IgorGO
МегаМодератор
СуперМодератор
 
Аватар для IgorGO
 
Регистрация: 05.02.2008
Адрес: УКРАЇНА, Київ
Сообщений: 9,102
Репутация: 1731

icq: 7934250
skype: i2x0,5
По умолчанию

вот и покажите пример, где считает не правильно
всего-то заполнить 3 ячейки А1, В1 и в любую скопировать написанную выше формулу
__________________
41001804815208 - Яндекс-деньги благодарности за удачные советы и решения можно отправлять прямо сюда)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете
IgorGO вне форума   Ответить с цитированием
Старый 26.01.2019, 20:50   #5
кувикин
Новичок
 
Регистрация: 25.01.2019
Сообщений: 3
Репутация: 10
По умолчанию

Цитата:
Сообщение от IgorGO Посмотреть сообщение
вот и покажите пример, где считает не правильно
всего-то заполнить 3 ячейки А1, В1 и в любую скопировать написанную выше формулу
первая строка ваша.
ниже тоже помогли. так как я в этом совсем не понимаю.
Вложения
Тип файла: xlsx Время_на_заявку.xlsx (9.5 Кб, 4 просмотров)
кувикин вне форума   Ответить с цитированием
Старый 27.01.2019, 03:10   #6
IgorGO
МегаМодератор
СуперМодератор
 
Аватар для IgorGO
 
Регистрация: 05.02.2008
Адрес: УКРАЇНА, Київ
Сообщений: 9,102
Репутация: 1731

icq: 7934250
skype: i2x0,5
По умолчанию

проделайте следующие операции:
откройте файл курсор в С1
формат ячеек
в открывшемся окне
закладка Число
в списке Числовые форматы самый последний пункт (все форматы)
увидите поле для ввода Тип
пишите в него [ч]:мм (скопируйте это в поле Тип)
Ок

видите в С1 вместо 1.75416666 стало 42:06?
а в С2 в это время написано 48:06
а у Вас вообще-то сколько вышло?
за период с Пт 18.01.2019 13:27:00 по Пт 25.01.2019 10:33:00???
18-го = 18:00-13:27 = 4:33
25-го = 10:33 - 9:00 = 1:33
19-е, 20-е - выходные, а 21,22,23 и 24 - это 4 рабочих дня по 9 часов рабочего времени (согласно Вашей методике) 4х9 = 36 часов
36:00 + 4:33 + 1:33 - это сколько будет? случайно не 42:06?
__________________
41001804815208 - Яндекс-деньги благодарности за удачные советы и решения можно отправлять прямо сюда)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете
IgorGO вне форума   Ответить с цитированием
Ответ

Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Расчет затраченного времени Lednikova Microsoft Office Excel 3 24.09.2012 18:48
расчет времени koda Microsoft Office Excel 1 21.02.2012 20:10
расчет времени между НАЖАТИЕМ и ОТПУСКАНИЕМ кнопки мыши BBOBAHH Общие вопросы Delphi 8 06.10.2010 21:13
Delphi подсчёт затраченного времени АлексаШка Помощь студентам 6 09.06.2010 08:51
Распределения работы по рабочим, по времени выполнения. Rhamzes Microsoft Office Excel 3 01.07.2009 15:04


23:20.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

RusProfile.ru


Справочник российских юридических лиц и организаций.
Проекты отопления, пеллетные котлы, бойлеры, радиаторы
интернет магазин respective.ru