Форум программистов
 
О проблемах, например, с регистрацией пишите сюда - alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail, а тут можно восстановить пароль.

Вернуться   Форум программистов > Microsoft Office и VBA программирование > Microsoft Office Excel
Регистрация

Восстановить пароль
Повторная активизация e-mail

Здесь нужно купить рекламу за 20 тыс руб в месяц! ) пишите сюда - alarforum@yandex.ru
Без учёта ботов - 20000 человек в день, 350000 в месяц.

Ответ
 
Опции темы
Старый 12.12.2019, 16:58   #1
Stas87
Новичок
Пользователь
 
Регистрация: 12.12.2019
Сообщений: 11
По умолчанию Exel Макрос или Формула

Добрый вечер! Помогите пожалуйста есть такая таблица Люди (строки) имеющие некоторое количество фруктов (столбцы) какую формулу или макрос применить чтобы считало автоматически, просто в действительности людей больше 10 тыс.
Вложения
Тип файла: xlsx Пример.xlsx (11.1 Кб, 9 просмотров)
Stas87 вне форума Ответить с цитированием
Старый 12.12.2019, 17:04   #2
digitalis
Старожил
 
Аватар для digitalis
 
Регистрация: 04.02.2011
Сообщений: 2,604
По умолчанию

Обязательно Excel? Нельзя применить какую-нибудь СУБД или написать прогу на "нормальном" ЯП?
digitalis вне форума Ответить с цитированием
Старый 12.12.2019, 17:13   #3
Stas87
Новичок
Пользователь
 
Регистрация: 12.12.2019
Сообщений: 11
По умолчанию

Все данные в екселе. А я немного не програмист(

Последний раз редактировалось Stas87; 12.12.2019 в 17:39.
Stas87 вне форума Ответить с цитированием
Старый 12.12.2019, 18:40   #4
сфинкс
Форумчанин
 
Аватар для сфинкс
 
Регистрация: 17.06.2012
Сообщений: 490
По умолчанию

цифры без формул неясно как задуманы

но возможно речь про формулы включающие знак доллара $

https://www.youtube.com/watch?v=I0QV2AZ5W5E

а пока внёс формулы насколько ясно условие
Изображения
Тип файла: jpg яблоки.jpg (61.3 Кб, 2 просмотров)
Вложения
Тип файла: xlsx Пример1212.xlsx (12.1 Кб, 6 просмотров)
учим C# зная basic & excel
https://programmersforum.ru/showthre...=327446&page=9

Последний раз редактировалось сфинкс; 13.12.2019 в 04:35.
сфинкс вне форума Ответить с цитированием
Старый 13.12.2019, 10:36   #5
Stas87
Новичок
Пользователь
 
Регистрация: 12.12.2019
Сообщений: 11
По умолчанию

Надо отфильтровать людей только те которые имеют 2 Яблока и один Абрикос как в 1 столбце (І) (Яблоки+Яблоки+Абрикосы) во втором только те которые имеют одно Яблоко и одну Вишню В столбце (К) только 1 Яблоко 1 Грушу и 2 Сливы и т.д.
Stas87 вне форума Ответить с цитированием
Старый 13.12.2019, 11:20   #6
Stas87
Новичок
Пользователь
 
Регистрация: 12.12.2019
Сообщений: 11
По умолчанию

Цитата:
Сообщение от сфинкс Посмотреть сообщение
цифры без формул неясно как задуманы

но возможно речь про формулы включающие знак доллара $

https://www.youtube.com/watch?v=I0QV2AZ5W5E

а пока внёс формулы насколько ясно условие
Сенк Чуть не то
Stas87 вне форума Ответить с цитированием
Старый 13.12.2019, 12:05   #7
Stas87
Новичок
Пользователь
 
Регистрация: 12.12.2019
Сообщений: 11
По умолчанию

Формула СЧЕТЕСЛИ Там где надо ставит 2 но формула прописана только к строкам F и В а надо ко всем отB доG, тогда получается абра( не могу придумать как правильно сделать
Изображения
Тип файла: jpg Безымянный.jpg (119.6 Кб, 1 просмотров)
Stas87 вне форума Ответить с цитированием
Старый 13.12.2019, 12:19   #8
Aleksandr H.
2 the Nation Glory
Старожил
 
Аватар для Aleksandr H.
 
Регистрация: 27.05.2014
Сообщений: 2,908
По умолчанию

Здесь нет логики в суммировании, придется один раз прописать суммы первого ряда, а дальше протянуть вниз
Кто умер, но не забыт, тот бессмертен.
Лао-Цзы.
Aleksandr H. вне форума Ответить с цитированием
Старый 13.12.2019, 12:24   #9
сфинкс
Форумчанин
 
Аватар для сфинкс
 
Регистрация: 17.06.2012
Сообщений: 490
По умолчанию

счётесли сообщает количество

=счётесли(b2:b12;"2")
например сообщит количество "2" в ячейках от b2 до b12

и сомневаюсь что нужны именно подсчёты

=СЧЁТЕСЛИ(B2;2)+СЧЁТЕСЛИ(F2;1)
=СЧЁТЕСЛИ(B2;1)+СЧЁТЕСЛИ(D2;1)
=СЧЁТЕСЛИ(B2;1)+СЧЁТЕСЛИ(C2;1)+СЧЁТ ЕСЛИ(E2;2)
=СЧЁТЕСЛИ(B2;2)+СЧЁТЕСЛИ(E2;4)

отсутствует проверка присутствия всех нужных в ячейке плодов

ход конём:
=(СЧЁТЕСЛИ(B2;2)+СЧЁТЕСЛИ(F2;1))*ЗН АК(СЧЁТЕСЛИ(B2;2))*ЗНАК(СЧЁТЕСЛИ(F2 ;1))
количества умножаются на знаки количества 1 или 0

без хотя бы одного из плодов? значит в ячейке 0
все плоды? значит в ячейке сумма
Вложения
Тип файла: xlsx счётесли1312.xlsx (12.1 Кб, 3 просмотров)
учим C# зная basic & excel
https://programmersforum.ru/showthre...=327446&page=9

Последний раз редактировалось сфинкс; 13.12.2019 в 12:45.
сфинкс вне форума Ответить с цитированием
Старый 13.12.2019, 12:56   #10
Stas87
Новичок
Пользователь
 
Регистрация: 12.12.2019
Сообщений: 11
По умолчанию

Цитата:
Сообщение от сфинкс Посмотреть сообщение
счётесли сообщает количество

=счётесли(b2:b12;"2")
например сообщит количество "2" в ячейках от b2 до b12

и сомневаюсь что нужны именно подсчёты

=СЧЁТЕСЛИ(B2;2)+СЧЁТЕСЛИ(F2;1)
=СЧЁТЕСЛИ(B2;1)+СЧЁТЕСЛИ(D2;1)
=СЧЁТЕСЛИ(B2;1)+СЧЁТЕСЛИ(C2;1)+СЧЁТ ЕСЛИ(E2;2)
=СЧЁТЕСЛИ(B2;2)+СЧЁТЕСЛИ(E2;4)

отсутствует проверка присутствия всех нужных в ячейке плодов

ход конём:
=(СЧЁТЕСЛИ(B2;2)+СЧЁТЕСЛИ(F2;1))*ЗН АК(СЧЁТЕСЛИ(B2;2))*ЗНАК(СЧЁТЕСЛИ(F2 ;1))
Припустим в столбце К правильно поставило 3 но если поставить 1 Абрикос тоже покажет как истина а это не правильно Нужно узнать только сколько человек имеет Яблоки+Яблоки+Абрикосы это 3 человека (правильно) или Яблоки+Груши+Сливы+Сливы это 1 человек (правильно) но если поставить еще какой то фрукт ничего не изменится
Вложения
Тип файла: xlsx счётесли1111.xlsx (11.9 Кб, 1 просмотров)
Stas87 вне форума Ответить с цитированием
Ответ

Здесь нужно купить рекламу за 20 тыс руб в месяц! ) пишите сюда - alarforum@yandex.ru
Без учёта ботов - 20000 человек в день, 350000 в месяц.

Опции темы


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
формула в EXEL =ЕСЛИ Борис1981 Microsoft Office Excel 3 01.06.2016 11:24
формула exel nobility969 Microsoft Office Excel 1 12.12.2013 15:36
Формула из Exel в PHP KoT3 Microsoft Office Excel 1 28.04.2011 23:27
Exel - при открытии файла через макрос, если файл отсутствует - виснет весь макрос gregory1b Microsoft Office Excel 2 14.10.2010 10:51
Нужна формула для прайса в Exel skoder Помощь студентам 3 23.01.2010 12:58


Проекты отопления, пеллетные котлы, бойлеры, радиаторы
интернет магазин respective.ru
Пеллетный котёл Emtas
котлы EMTAS
Здесь нужно купить рекламу за 7 тыс руб в месяц! )
пишите сюда - alarforum@yandex.ru
ИКС 840