Форум программистов
 
О проблемах, например, с регистрацией пишите сюда - alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail, а тут можно восстановить пароль.

Вернуться   Форум программистов > Web > HTML и CSS
Регистрация

Восстановить пароль
Повторная активизация e-mail

Здесь нужно купить рекламу за 20 тыс руб в месяц! ) пишите сюда - alarforum@yandex.ru
Без учёта ботов - 20000 человек в день, 350000 в месяц.

Ответ
 
Опции темы
Старый 04.04.2019, 10:19   #1
exivmaks
Пользователь
 
Регистрация: 03.03.2015
Сообщений: 10
По умолчанию Парсим сайт из 1с

Здравствуйте уважаемые, не кидайтесь кирпичами пожалуйста. )))

Есть сайт .

Хочу выдернуть товары (название и ссылки на них) и положить в табличную часть.
Сам сайт подгружается в 1С, а вот с таблицей проблемы.
Что делаю не так?
Код:
Процедура КнопкаВыполнитьНажатие(Кнопка)
    // Вставить содержимое обработчика.
    
    ЭлементыФормы.Сайт.Перейти("http://cto.r-75.ru/?cat=78");
КонецПроцедуры
 
Процедура Заполнитьпроизводителей(Кнопка)
    
    Для Каждого Стр из ЭлементыФормы.Сайт.Документ.body.all Цикл
        Если Стр.tagName = "h1" и Стр.innerText = "Витрина"  Тогда
            Для Каждого опСтр из Стр.nextSibling.children Цикл
                новСтр = ЭлементыФормы.Нашсайт.Страницы.Производители.Добавить();
                новСтр.Наименование = опСтр.titleText;
                новСтр.Ссылка = опСтр.firstChild.href;
            КонецЦикла;
            Возврат;
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры
Спасибо огромное.
exivmaks вне форума Ответить с цитированием
Ответ

Здесь нужно купить рекламу за 20 тыс руб в месяц! ) пишите сюда - alarforum@yandex.ru
Без учёта ботов - 20000 человек в день, 350000 в месяц.

Опции темы


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
парсим на php - помогите разобраться с проблемой. Armatus PHP 12 13.01.2014 14:12
htmlagilitypack парсим текст SnaiperArts C# (си шарп) 0 14.10.2013 23:09
Парсим текст, не могу вникнуть antoxamad Помощь студентам 7 23.02.2012 09:02
Парсим bash.org.ru Merkator Работа с сетью в Delphi 1 21.04.2009 20:21


Проекты отопления, пеллетные котлы, бойлеры, радиаторы
интернет магазин respective.ru
Пеллетный котёл Emtas
котлы EMTAS