Форум программистов
 
Контакты: о проблемах с регистрацией, почтой и по другим вопросам пишите сюда - alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail.

Вернуться   Форум программистов > Microsoft Office и VBA > Microsoft Office Excel
Регистрация

Восстановить пароль
Повторная активизация e-mail

Здесь нужно купить рекламу за 25 тыс руб в месяц! ) пишите сюда - alarforum@yandex.ru

Ответ
 
Опции темы
Старый 25.08.2009, 20:44   #1
segail
Форумчанин
 
Регистрация: 13.06.2009
Сообщений: 688
По умолчанию #ЗНАЧ!

Добрый вечер.
Подскажите как исправить #ЗНАЧ! на ноль?
Вложения
Тип файла: rar znah.rar (7.6 Кб, 20 просмотров)
segail вне форума   Ответить с цитированием
Старый 25.08.2009, 20:50   #2
EducatedFool
Программист VBA
СуперМодератор
 
Аватар для EducatedFool
 
Регистрация: 13.07.2008
Сообщений: 6,840
По умолчанию

Например, немного переделать формулу:
Код:
  Ячейка: O6      Формула  (стиль A1):   =ЕСЛИ(K6=0;"";(L6/(K6+Ч(M6))*N6))
                  Формула  (стиль R1C1): =ЕСЛИ(RC[-4]=0;"";(RC[-3]/(RC[-4]+Ч(RC[-2]))*RC[-1]))
EducatedFool вне форума   Ответить с цитированием
Старый 25.08.2009, 21:08   #3
segail
Форумчанин
 
Регистрация: 13.06.2009
Сообщений: 688
По умолчанию

А если переделать формулу в ячейки М6
Код:
=ЕСЛИ(V5=0;””; (K6*(T5*U5+V5)/(T6*U5+V5)-K6))
на
Код:
=ЕСЛИ(V5="";0; (K6*(T5*U5+V5)/(T6*U5+V5)-K6))
Так вроде ни каких сбоев при вычислении, и ошибок нет.
Вложения
Тип файла: rar znah.rar (7.7 Кб, 8 просмотров)
segail вне форума   Ответить с цитированием
Ответ

Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Выдиление цветом макс. знач. Slavik Microsoft Office Excel 8 04.05.2009 10:11
Почему так? Знач. по умолч. у функции and277 Общие вопросы C/C++ 9 14.03.2008 18:53


04:59.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.