Форум программистов
 
Контакты: о проблемах с регистрацией, почтой и по другим вопросам пишите сюда - alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail.

Вернуться   Форум программистов > Web > HTML и CSS
Регистрация

Восстановить пароль
Повторная активизация e-mail


Донат для форума - использовать для поднятия настроения себе и модераторам

А ещё здесь можно купить рекламу за 15 тыс руб в месяц! ) пишите сюда - alarforum@yandex.ru

Ответ
 
Опции темы
Старый 04.04.2019, 11:19   #1
exivmaks
Пользователь
 
Регистрация: 03.03.2015
Сообщений: 10
Репутация: 10
По умолчанию Парсим сайт из 1с

Здравствуйте уважаемые, не кидайтесь кирпичами пожалуйста. )))

Есть сайт .

Хочу выдернуть товары (название и ссылки на них) и положить в табличную часть.
Сам сайт подгружается в 1С, а вот с таблицей проблемы.
Что делаю не так?
Код:

Процедура КнопкаВыполнитьНажатие(Кнопка)
    // Вставить содержимое обработчика.
    
    ЭлементыФормы.Сайт.Перейти("http://cto.r-75.ru/?cat=78");
КонецПроцедуры
 
Процедура Заполнитьпроизводителей(Кнопка)
    
    Для Каждого Стр из ЭлементыФормы.Сайт.Документ.body.all Цикл
        Если Стр.tagName = "h1" и Стр.innerText = "Витрина"  Тогда
            Для Каждого опСтр из Стр.nextSibling.children Цикл
                новСтр = ЭлементыФормы.Нашсайт.Страницы.Производители.Добавить();
                новСтр.Наименование = опСтр.titleText;
                новСтр.Ссылка = опСтр.firstChild.href;
            КонецЦикла;
            Возврат;
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры

Спасибо огромное.
exivmaks вне форума   Ответить с цитированием
Ответ

Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
парсим на php - помогите разобраться с проблемой. Armatus PHP 12 13.01.2014 15:12
htmlagilitypack парсим текст SnaiperArts C# (си шарп) 0 15.10.2013 00:09
Парсим текст, не могу вникнуть antoxamad Помощь студентам 7 23.02.2012 10:02
Парсим bash.org.ru Merkator Работа с сетью в Delphi 1 21.04.2009 21:21


19:56.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

Проекты отопления, пеллетные котлы, бойлеры, радиаторы
интернет магазин respective.ru