Форум программистов
 
Регистрация на форуме тут, о проблемах пишите сюда - alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail, а тут можно восстановить пароль

Купить рекламу на форуме 15-35 тыс рублей в месяц

Вернуться   Форум программистов > Microsoft Office и VBA программирование > Microsoft Office Excel
Регистрация

Восстановить пароль
Повторная активизация e-mail

Ответ
 
Опции темы Поиск в этой теме
Старый 08.06.2009, 20:01   #1
Alexvolk
Новичок
Джуниор
 
Регистрация: 08.06.2009
Сообщений: 1
По умолчанию Дата понедельника по номеру недели. Excel

Всем привет.
Дано: номер недели текущего года.
Найти: дату понедельника этой недели.
Как используя только формулы найти первый день недели?

Например для шестой недели понедельник это 06.02.09

Подскажите решение плз.
Alexvolk вне форума Ответить с цитированием
Старый 08.06.2009, 20:35   #2
IFRSoff
Форумчанин
 
Аватар для IFRSoff
 
Регистрация: 23.02.2009
Сообщений: 306
По умолчанию

06/02/2009 это пятница шестой недели. А вот понедельник можно искать по такой формуле массива для 2009 года.
Цитата:
=ИНДЕКС(39813+СТРОКА(ДВССЫЛ("1:365" ));ПОИСКПОЗ(A1;НОМНЕДЕЛИ(39813+СТРО КА(ДВССЫЛ("1:365"));2);0);0)
Первую неделю только неверно выдаст, а все остальные пучком
Лень - двигатель прогресса!

Последний раз редактировалось IFRSoff; 08.06.2009 в 21:49.
IFRSoff вне форума Ответить с цитированием
Старый 09.06.2009, 01:30   #3
ZORRO2005
Форумчанин
 
Аватар для ZORRO2005
 
Регистрация: 26.11.2006
Сообщений: 584
По умолчанию

Можно и проще:
=39807-ДЕНЬНЕД(39814;3)+7*A1

Последний раз редактировалось ZORRO2005; 09.06.2009 в 01:39.
ZORRO2005 вне форума Ответить с цитированием
Ответ
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Помогите,пожалуйста, сдать зачёт!(задачи нужны до понедельника) Nastia Помощь студентам 3 16.05.2009 20:29
задачи по Паскалю до понедельника ЯН_КА Помощь студентам 12 17.04.2009 23:19
Копирование данных типа Дата из Excel в mdb таблицу Dimok82 БД в Delphi 0 14.03.2009 11:34
сумма чисел по номеру anatolin Microsoft Office Excel 10 29.01.2009 19:02
Дата Конечная (ДД.ММ.ГГГГ) - Дата Начальная (ДД.ММ.ГГГГ) = Количество Месяцев stanislav24 Microsoft Office Excel 5 20.12.2008 10:36